Some devices need to be assigned a static IP. This article will show you how to create a DHCP lease that will ensure your device gets the IP address it needs on your network.

Things you'll need:

  • The MAC address of the device you want to assign the static IP to
  • The IP address you want to assign to that device
  • SSH access to the MikroTik gateway for that network

Firstly, login to the gateway of the network via SSH using the Minim Care Portal.

You will run the following command, changing:

MACADDRESS to the MAC address of the device

IPADDRESS to the IP address you want to assign

/ip dhcp-server lease add address=IPADDRESS client-id=1:MACADDRESS mac-address=MACADDRESS server=defconf use-src-mac=yes

Here's an example of what this might look like assuming a mac address of: aa:bb:cc:dd:ee:ff and an IP address of 192.168.88.10

/ip dhcp-server lease add address=192.168.88.10 client-id=1:aa:bb:cc:dd:ee mac-address=aa:bb:cc:dd:ee server=defconf use-src-mac=yes

Please don't hestitate to contact us if you have any trouble doing this.

Did this answer your question?